Traveler Support for the Latest Device Updates

For a list of the currently supported devices, please reference the Lotus Notes Traveler System Requirements.

For the latest Lotus Traveler code updates, including Fix Packs, always check the Lotus Notes Traveler Recommended Maintenance page.

Apple iOS 6 and iPhone5 Support:
For 8.5.3.x: Please apply Traveler 8.5.3.3 IF1 or later, which is found on the
Recommended Maintenance page.

For 8.5.3 UP1: Please apply Traveler 8.5.3 UP1 IF1 or later, which is found on the
Recommended Maintenance page.
Note:  iOS 6 and iPhone5 are supported on Traveler 8.5.3.x or 8.5.3 UP1.

Android 4.0 and Apple iOS 5 Support:
For 8.5.3.x: Please apply Traveler 8.5.3.2 or later, which is found on the
Recommended Maintenance page.

For 8.5.2.x: Please apply Traveler 8.5.2.4 HF1 or later, which is found on the
Recommended Maintenance page.


Devices Under Evaluation for Possible Future Support:

  • For the BlackBerry PlayBook device support statement, please reference this technote.
  • As mentioned in this IBM press release, IBM intends to support Microsoft Windows Phone in a future release of IBM Lotus Notes Traveler.  IBM intends to support several devices such as the Nokia Lumia line and some from HTC.
  • For the Kindle Fire or Barnes & Noble Nook Android device support statement, please reference this technote.